*NEW BIOS* m18xR1 A05 Bios FULLY UNLOCKED modded iRST 12.9.0 OPROM w/RAID0 TRIM, IME 7.1.80

#1
Hey Everyone,
So, I was FINALLY able to MOD the A05 BIOS to be FULLY UNLOCKED with the following updates:
OpRom 12.9.0... It supports RAID0 TRIM, AND it also give you the accelerate option within the Intel Raid Manager GUI. Also, this BIOS is FULLY UNLOCKED, so you will have MANY MORE options to choose from. Lastly, I have the Intel ME 7.1.80... firmware upgrade as well! I've tested it on my system and it's worked PERFECTLY (Both the IME & Bios). I also have the older iRST OpRom's too. So, if you want the Intel OpRom v10.1, 10.8, 11.2, 11.6, or 12.9.0, let me know... ALL of the iRST OpRoms have been modded to FULLY SUPPORT TRIM on RAID0. (Anything after 11.2 is supposed to pass TRIM through to the controller, but for some reason it didn't on some of the older mobile 6-series systems (like our HM67)! Anyway, if you are interested in the upgrade tool (it runs in windows and takes about 2 minutes to do or less), please send me a PM. I'm looking to give this away for free, but need testers! It worked for me, and another person that was kind enough to test it for me, but he had to reinstall OS. So, that is the biggest risk. Make sure you BACKUP all of your data first! :)
I hope to hear from ya'll soon!
Thanks,
Swick
PS. It's CONFIRMED with TRIMTOOL that TRIM works in RAID0.
I can also add iRST v13, but I'm told the best iRST for the mobile chipset HM67 series-6 laptop is 12.9.0 - But I can change it to v13 if anyone is interested. Let me know!
 
#3
no, however... IF you supply me with the BIOS for the m18xR2, I can probably update the microcode & bios for you with the newest OPROM! (I'd have to research what your chipset is, and what the best iRST oprom would be, etc...) But, you can certainly use the IME update that I have. Here is a link to the downloads:
https://www.dropbox.com/sh/qlty4chq2f02n03/AABaofHk4f7fQT5HbH4xtuk1a?dl=0
Look for the IME folder and you may be able to update IME. I'm not sure what version you are running, but I do have the 7.1.80 IME available for download, and that should work for you - ASSUMING you are running a lower version. CHECK before you do anything. Send me a PM and I'd be happy to help! :) (IF you are running v8 or higher, DO NOT USE this update!) CHK in bios the ime version you are using, first, then report back to me!
Thanks,
Swick