17R3 No Boot device?

GracieAllen

Member
Joined
May 9, 2021
Messages
9
This laptop was mine for 5 years. Wife inherited it about a year ago. It boots from a 256GB SSD.

Sometimes at boot - not exactly sure WHEN, it fails and says there's no boot device. Press F1 and it goes off and boots fine.
It ALSO, sometimes throws the BSOD with an Inaccessible boot device error.

I've removed the SSD, reseated it, it appears fine.

CrystalDiskInfo says there's NO problem. Everything is perfect.

The OTHER part of what it's doing - and I THINK it may be related: If I close the lid, when I open it the screen is blank, stays blank. Fans run, lights are on, but the only thing you can do is crash it. POWER is currently set NEVER TO SLEEP. No turning off the display, no sleeping, no hibernating, NOTHING. It SHOULDN'T care whether the lid is up or down...

I don't know if I have 1 problem or 2. I just powered it off after the black screen and it booted PERFECTLY... I just did a second reboot and it worked perfectly. Did a full shutdown and restart and THAT worked perfectly.

do I have an SSD going bad? Can I move it from SSD 1 to SSD 2 and see if that works? Of course, since I can't prove a negative, I'll only find out something if it DOESN'T work. but... Will it boot from SSD2?

And MOST importantly, what's up with the black screen - I saw some VERY OLD topics about the problem, but everything kept saying it was fixed...

What do now?
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
3,046
Hello. It can be hard to know exactly what your issues are related to without testing it personally but it does sound like you could have a drive issue. The lid closing issue could also be related to this. If you can get get to the splash screen while booting then quickly press F12 to get into the Boot menu. Select the Diagnostic and the machine will go through the ePSA to check for hardware issues.
You can also check to see if your main SSD is still selected as the primary boot device. Press F2 during boot to get into the BIOS. Select the Boot tab and see if your main drive is on the top of the boot list. Don't make any changes in the BIOS unless you know what you're doing.
Physically moving the SSD to the other slot could be worth a try. You'd just need to make sure that it's still listed as the primary boot device in the BIOS after you swap it.
 

GracieAllen

Member
Joined
May 9, 2021
Messages
9
I've done the diagnostic and let it churn through everything. No issues whatsoever.

I've also been in the BIOS, presuming I could do the normal "tell it what to boot from, in what order." There isn't one that's obvious to me. The boot section in the BIOS has:
Boot List Option [UEFI] -- the other option is Legacy
File Browser Add Boot Option - this has ONE option, for the SSD it's already using to boot from. I can add this as a boot option, but I thought the UEFI was supposed to take care of all this.
And if I AM supposed to add this as a boot option, which media file do I select from the menu?

Secure Boot is Disabled
Load Legacy Option rom is disabled

Boot option 1 is is [Windows Boot Manager]
Boot option 2 and 3 are Onboard NIC (IPV4) and (IPV6)

BTW: The system has booted perfectly a half dozen times this afternoon and is running PERFECTLY - as LONG AS you don't allow it to turn off the display or put the lid down. Then it's the black screen, lights on, fans spinning, and no way to do anything but crash it.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
3,046
No, it looks like everything is set up as it should be. It seems like it's going into sleep/hibernate mode and won't turn the display back on

You could try some of the fixes in the link below. Update your BIOS at your own risk though

https://windowsreport.com/windows-1...ination you should try,on from the Sleep mode.

When all else fails, I usually go for a clean Windows installation.

Do you know if your laptop is just using a single drive to run the OS or do you have a RAID setup with multiple drives? I've had the inaccessible boot device issue but the BIOS was set to RAID instead of AHCI.
 

GracieAllen

Member
Joined
May 9, 2021
Messages
9
It's just a single drive - 256GB Samsung NVME SSD.
There's usually a secondary HDD in there but it's sitting on the shelf right now.
No dongles, no cables, no hdmi, no nothin'. Just a power plug and the laptop. 1 SSD, 16GB memory, and that's it.

I BELIEVE I tried to update the BIOS when all this started, but it failed. I'll download it again and try it. As FAR AS I KNOW, the current version is
1.12.0 that came out in April.

I followed the instructions, put the file in a folder, ran it in Windows as the instructions said, and it tried to update then said it failed.

I'll give it another try.
 

GracieAllen

Member
Joined
May 9, 2021
Messages
9
I just retried the BIOS update and this time it was successful. The laptop now has 1.12.0 for the BIOS.

Unfortunately, it still won't wake up when it shuts off the display. I've got it set to turn off the display after 2 minutes and NEVER to sleep. Display goes off, system stays up, screen goes black, no errors, no nothing, and it has to be crashed.
 

GracieAllen

Member
Joined
May 9, 2021
Messages
9
Sorry to keep updating but I'm trying things and it keeps expiring the edit time.........

Wife needs to do stuff, so I put the laptop back in her spot, plugged it into the secondary monitor, put in the dongle for the wireless mouse and keyboard. Booted, everything's fine.

After 2 minutes the display get shut off. Hit keys on the laptop, nothing. Wiggle the wireless mouse - WAKES UP.
Did it again, with the same results.
Tried letting it sit longer - here's something I didn't notice. When it shuts off the display, the hard drive gets VERY busy - MUCH flashing of LED. This goes on for 30-40 seconds, then it stops.

I DIDN'T try waking up the display after an extended period like a minute, but it DEFINITELY wakes up after 10 or 20 seconds.

SO, my next question is - what's all the disk activity that's going on when the monitor shuts off? Is it doing something goofy like writing all the contents preparing to go into hibernation? If so, why? I've got hibernation turned OFF. It SHOULD NEVER hibernate - or even sleep.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
3,046
Can't explain that one sorry. At this stage I would try reinstalling or resetting Windows but that is a huge pain if you have lots of programs/data that you don't want to lose or have to reinstall.
You could try reinstalling your Intel/Nvidia display drivers but I doubt that would help. It's possible you have a little Windows bug.
 

GracieAllen

Member
Joined
May 9, 2021
Messages
9
It's going to get weirder.......

Laptop set up for my wife - 2nd monitor, wireless mouse and keyboard. Display set to shut off after 1 minute (I don't have the patience to wait 20 when testing).
Display goes off, lots of flashing disk activity, wiggle the mouse wakes up - 20-30 seconds.
Repeat and wait 60 seconds. Wakes up.
Repeat for 5, 10, 20, 30 and 45 MINUTES. Wakes up EVERY TIME. Without the wireless devices I wasn't able to wake it with the laptop keyboard after a second or 2.
At SOME POINT - longer than 45 minutes, it freezes. I don't know how long this IS, but it's SOMEWHERE between 45 minutes and about 2 1/2 hours... But at SOME POINT, it won't "wake up" and you have to crash it.

Does ANYBODY know of ANY settings buried in Windows or the alienware that would cause this? 'Cause at this point the Windows 10 forum doesn't appear to have a clue, and it sounds like nothing here either...

Fortunately, there's not a lot of important stuff on this box, so I can pull the SSD, put in a spare 256GB SSD, install Windows and see if it makes any difference, but this whole thing is bizarre - WHAT in Windows would even CARE whether the lid is closed?
 

GracieAllen

Member
Joined
May 9, 2021
Messages
9
The saga continues...
I finally gave up, pulled the SSD OUT of the laptop, stuck in a blank one and installed a BRAND NEW, SHINY copy of Windows 10 Pro. And had it go through the 312 updates needed to get it current.

There's ABSOLUTELY NOTHING on the box except Windows. No installed software, no installed antivirus, no installed nothin'. I've even using Edge for a browser.

It does what appears to be almost THE SAME THING.

I have the display set to shut off after 20 minutes. ALMOST all the time if I let it turn off the display it won't come back on. Once or twice I've let it turn off and it did. But it's NOT consistent or reliable. BUT, MOST OF THE TIME I can CLOSE the lid now and when I open it, it'll come up with the lock screen where you can log in.
But almost ALWAYS if I leave it logged in, when it shuts off the display, it won't turn it back on.

Even THOUGH it was never hot and never had a shutdown, I disassembled the thing, cleaned all the vents - which had NOTHING in them, and repasted the GPU and CPU. The old grease looked fine and hadn't gotten hard or nasty, but after spending an hour getting it apart... I WANT to believe it quieted the fans, 'cause otherwise I wasted 2 hours, so I'll go with "it's quieter"...

If it's a POWER problem I don't know what - I currently have it using the default "balanced" setup. It's PLUGGED IN so I don't care about the on-battery settings at the moment. I HAD it at the defaults originally, and it wouldn't wake up. So, I went in and changed
Turn off hard disk after 20 minutes
Intel Explorer>Javascript timer frequency Maximum Performance
Desktop background>Slide Show Available
Wireless Adapter Settings>Power Saving Mode Maximum Performance
Sleep
Sleep after NEVER
Allow Hybrid sleep OFF
Hibernate after NEVER
Allow wake timers Important Wake Timers Only --- should this be Enable instead?
USB settings>USB selective suspend Enabled
Intel Graphics Settings>Graphics Power Plan Balanced
PCI Express > Link State Power Management OFF
Processor power management
Minimum 5%
System Cooling policy Active
Maximum processor 100%
Display>Turn off the display after 20 minutes
Multimedia Settings
When sharing media prevent idling to sleep
Battery
Critical battery action Do Nothing

I don't remember where - but isn't there SOME power setting to tell it what to do when you close the lid?


Is there ANYTHING in the BIOS that can tell it not to wake up? As far as I know it's all DEFAULTS. If there's something that SHOULD be changed, let me know... I sure HOPE there's something stupid in the BIOS, but don't know why there would be...
Intel Speedstep enabled
Virtualization enabled
Integrated NIC enabled
USB emulation enabled
USB Powershare enabled
USB Wake Support Disabled - should this be enabled?
SATA Operation RAID - there's NEVER been a RAID anything in this box, but it doesn't seem to care.
Adapter Warninger Enabled
Function Key Behavior Function Key
Express Charge Standard Charge
Touchbad Backlight Auto

Intel Software Guard Extensions Disabled

Performance Options
CPU Performance Mode (I believe this does overclocking) DISABLED
Fan Performance Mode (I believe this is used when overclocking) DISABLED

Intel Rapid Storage Technology says there's a NON-RAID physical disk, and knows there's a Samsung SSD in there.

I'm out of ideas. As far as I know I've tried reasonable stuff like power settings and unreasonable stuff like taking the whole thing apart. It still appears to do the same thing - at 20 minutes the display goes dark, the system stays up, lights are on, fans spin, but NO display wakes up... Same thing if you close the lid.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
3,046
If you type 'Change what happens' into the Windows search bar you should get a prompt to be able to change the power settings including closing the lid settings.
If a fresh Windows installation hasn't changed anything then it points to a hardware issue. It could either be a graphics or LCD problem. I really hope that it isn't though.
USB wake support allows a USB device to wake the laptop. I would have thought that this would be enabled as default. Even if this is disabled then your inbuilt keyboard should still wake the laptop. You could try enabling it or even restoring your BIOS to default settings. If you don't know much about BIOS settings then it's best to to meddle too much.
Systems can run fine with RAID enabled even though there are no RAID disks set up. I prefer to switch it to AHCI though if I'm not running RAID. Be careful switching this as it can sometimes make you reinstall Windows again.
 

GracieAllen

Member
Joined
May 9, 2021
Messages
9
I don't know where my reply from yesterday went - I probably got interrupted in the middle and lost it........

BUT, for NO reason I can fathom, the laptop is fine. When it had NOTHING on it but the O/S, it went black when you closed the lid or the display turned off. I watched it do that for a couple days.

Yesterday I put some of the software on it, and it now works perfectly. Put the lid down, it does whatever. Open the lid, a second later there's some disk activity and a second after that it comes up on the lock/login screen. Let it sit and the display goes black, wiggle the mouse and it comes back on...... I have NO idea WHY having Office and Zoom on there would make ANY difference, but B followed A so I'm going to say A CAUSED B.

I suspect one of these days it'll go nuts again and start locking up, and when it does I'll come back to see if we can get it fixed, but at the moment my wife has it hooked up to all her stuff - second monitor, wireless mouse and keyboard - and it's acting totally normal.......

Thanks for the help.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
3,046
Very strange. It could have been a Microsoft update that happened in the background that made the difference. Possibly a system driver.
Windows updates sometimes cause crazy things to happen to drivers until the device manufacturers update their drivers to suit the Windows update.
Anyway, hopefully it never comes back for you
 

GracieAllen

Member
Joined
May 9, 2021
Messages
9
I hope so too, but I figure no good deed goes unpunished - if it WAS something in an update that isn't a problem at the moment - they'll find a way to break it again in a future update and the laptop will go nuts again!
 
Top