test

Alienware 17 R5 Keyboard Stopped Working

Paperlanterns98

New Member
Joined
Feb 27, 2019
Messages
2
2-3 months ago I purchased a brand new Alienware 17 R5 laptop... with per-key RGB keyboard. Everything was fine the first month or so, then my keyboard stopped typing entirely, but still lights up (lights). The keyboard to this day still works in BIOS and Diagnostics, but not at all in Windows.
Out of desperation, I did a Local Restore (F12). No effect. Then I tried a “Cloud Factory Restore”. Initially, no effect. I left my laptop on while I went to work and then returned to it and my keyboard was working again. Therefore I do not know exactly why it started working. It continued to work for a couple of weeks then stopped again. Unable to find a resolution, I tried another Cloud Factory Retore, since that seemed to somehow work before. Nope, it’s been a week and keyboard still does not type in Windows. I have spent this week communicating with Dell Tech Support and they seem to be running me through a long arduous script that isn’t resolving anything. Alienware Command Center is showing me having the standard 4-zone keyboard, and isn’t responding to lighting changes (not that I expect it to as that’s not the keyboard I physically have). The big question is why it’s not recognizing my per-key RGB keyboard. Is AWCC responsible for installing the correct keyboard driver(s)? I also don’t understand what is causing the intermittent issue, or why it keeps happening. Since the keyboard works outside of Windows, I believe the keyboard is physically fine, and the problem is a Windows driver or a poorly written Command Center. I mostly rule out a Windows update, as the keyboard doesn’t work with or without doing any Updates.
I would greatly appreciate help from very knowledgeable fellow owners.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,961
That sucks. Dell should be doing more than that to help you. It sounds possibly like a motherboard issue. I would consider a loose connection to the mobo but if it works in the bios then it couldn't be.
Alienware now have an official Reddit account so I would probably try them there if you aren't getting the support from Dell Support. Have you uninstalled/reinstalled AWCC?
 
Top