Alienware 17r3 2.5" SSD Upgrade

Ben

New Member
Joined
Apr 4, 2015
Messages
1
Hi everyone

First post on the forum , has anyone upgraded the 2.5" HDD inside the laptop? I have the 17r3 that came with a 1tb 7200 drive and I am trying to replace the drive with a Crucial SSD from my old M17x R4. When the Sata connection is set to ACHI the SSD cannot be seen by the BIOS. When I set the Sata type to raid the SSD can be seen in the BIOS but I cannot install anything as I cannot find the correct raid drivers.

I have tried other Alienware/Dell Drivers but it will not find the SSD when installing Windows.
I have tried running in AHCI mode and adding the drivers during the windows install but it does not find the drive as it is not detected in the BIOS.
I Have tried re-installing a factory image on the machine, This did not as the SSD was not in the BIOS and the factory image does not include raid drivers
I have tried the SSD in another laptop to make sure it was working (17r3 bios detects the drive in Raid Mode only).
I have wiped the drive and made it bootable using diskpart from within windows using the ssd as an external hdd but still the same issue.

I have now run out of things to try, Anyone done this before that may know what I am doing wrong.

Cheers
 

Josh G

New Member
Joined
Jul 27, 2016
Messages
3
Look at it this way- OS drivers have absolutely nothing to do with BIOS detection. Check Dell release notes to ensure there were no BIOS/firmware updates addressing this. (I don't usually update a BIOS/Firmware without cause or good reason.) Try another SSD. Perhaps the Crucial SSD you have has an available firmware update? There isn't a whole lot to look at here. I'd lean towards the SSD as the culprit here.
 

Alienwulf

Member
Joined
Jan 20, 2014
Messages
238
Not sure if you found the problem if not try cloning the SSD first. HDCLone is free then see if it will boot. If not then I agree with Josh's answer.
 
Top