Alienware Aurora r10 Ryzen Edition Won't Boot

justinaylmao

New Member
Apr 29, 2021
1
0
NJ
Hi everyone,

I recently purchased an Alienware Aurora r10 with a Ryzen 7 5800X in it. Upon receiving the PC, I immediately switched out the CPU for my Ryzen 5 3600X, without booting up the PC first (oops).

I put the 5800X in my pc and everything works, but upon giving the Alienware PC to my little brother with my old 3600X (which I know works), the PC won't boot.
The CPU fan spins up and continues to spin at max speed the whole time, and the GPU fan spins upon turning on the power but turns off after 5 seconds.

I can't pinpoint the issue because I never tried to boot up the PC when I got it, so now I'm just reasoning about what it could be.
Is it possible that the motherboard can handle the 5800X that the prebuilt came with, but not the 3600X for some reason? I thought x570 boards were compatible with Ryzen 3000 & 5000.
I've tried reseating the RAM and using my own RAM (which I know works), but that didn't work. I also tried switching out the GPU and that didn't work, so I'm guessing it's a CPU problem or motherboard issue?

Thank you all in advance
1f642.png