Alienware M14x KillerNIC Wired Ethernet Adapter disappeared

FelixFTW

New Member
Joined
Feb 11, 2016
Messages
2
Recently a strange thing happened. I powered on my laptop and had no network. It worked before I left for work, but not when I returned home at the end of the day.

I checked Device Manager and the internal wired Ethernet adapter (Killer NIC) was not visible. I turned on 'show hidden devices' and the adapter was grayed out and indicated it was not activated. The adapter status says "Currently, this hardware device is not connected to the computer (code 45)"

The card adapter is model: Killer e2200 Gigabit Ethernet Controller (NDIS 6.30). The Driver File Details are: Qualcomm Atheros, Inc 8.0.2.42 For troubleshooting, I attempted the following:

Searching for updated drivers

Turning the adapter off and on within the bios

Performing a system restore

Reinstalling the card in device manager (by removing it and scanning for hardware changes)

Reinstalling Windows

Upgrading Windows to 10 Pro

Nothing worked. Its acting like the NIC just disappeared! I have done absolutely nothing to cause the device to be "not connected to the computer". I'm so frustrated!!!

I'm having other issues with this machine as well. Frequently it will not boot and has a series of ~ 7 beeps. I've had to power it down and back up many times and then will get 'lucky' and it will boot again.

Finally, I removed the battery and it seems to be booting normally. Over the ~ 1 yr since I bought this machine, I've had the unit plugged in to power the entire time except for about 5 days of travel.

I don't understand what is happening. Seems like a motherboard issue to me.

Does anyone have insights on this? Has anyone seen this before?

Thanks in advance for your feedback.

FelixFTW
 
Top