alienware m17x r3 black screen after gpu driver update

mondoman

New Member
Dec 7, 2019
1
0
Grc
specs

Model:
Alienware M17X-R3
Operating System:Windows 7
Processor Type:Intel Core i7 2nd Gen. - 2860QM
Operating System Edition:Home Premium

Graphics Processing Type:
Nvidia Geforce GTX 580M
Hardware Connectivity:VGA, LAN, Microphone Port, Headphone Port, HDMI, USB 2.0, USB 3.0, SD Card Slot, 5 x USB Ports, 2 x Headphone Ports
Memory:16 GB
Hard Drive Capacity:1 TB

refurb comp i bought from ebay,
i intend to use it to run Second Life as it has specs twice as good as the computer from which i am currently typing, although i am having a few issues. i tried to launch the SL viewer and got hit with an error message

"firestorm is unable to run because your video card drivers did not install properly, are out of date or are for unsupported hardware. please make sure you have the latest video card drivers and even if you do have the latest, try installing them. if you continue to recieve this message, contact the SL support portal."

at this point i began searching for a solution. figured it was related to the gpu driver and tried to update the "standard vga graphics adapter" driver to the most recent (i tried updating this two times an older version from 2015 which had the same result but i could atleast access safemode to rollback and the newest which has left me in a bricked scenario) , after doing so and restarting the computer i was hit with a black screen, no bios prompt, no options to start windows in safemode, computer starts up but the screen is black. so i can't launch secondlife for whatever reason, and i'm trapped on a black screen with no way of doing a driver rollback to atleast fix the display.

at one point i also tried to access the nvidia control panel with no success in task manager there was an nvidia process (i'm not sure if it was for the control panel) but the control panel itself would not open.
 

MattyB

Moderator
Mar 19, 2012
3,097
125
Adelaide, Australia
Do you have the 3D 120Hz display? If you don't then pull the 580M out of the machine and you'll boot from the intel graphics. If you do have the 3D display then you may have to use a Bootable Windows CD/USB to do a fresh windows install.

I am trying to repair a 17 R1 at the moment and I'm getting a black screen when I try to install the 880M drivers. I can install and run the card in safe mode though. It's a hardware issue with the card. Safe mode does not use all the cards power so it can run ok but as soon as you try to run the card properly it can't handle it. My 880M is all but dead and I'm assuming the same thing is happening with your 580M.
I spent all weekend trying to work it out.