Alienware X51 newbie, a question re accessing BIOS

Hi,

I've not long had the X51, its currently set up as a media centre pc. It was a refurb and I have this currently hooked up to a telly to a wireless keyboard mouse for non media centre stuff, I was looking to access the BIOS to change the boot order options but I note that there is no boot options when the pc starts, it just kicks into the Alienware head picture boot screen.

I'm thinking this may be due to the X51 not recognizing the wireless keyboard mouse in the pre-boot environment, I'm trying to source a USB cabled keyboard, does anyone know if this will work and allow for entry into the BIOS and are there any complications in accessing the BIOS?

I tried booting off a USB version of Windows 7 & a Windows 7 CD but no luck, battering away at F11, F12, DEL ect didn't work.

My X51 came without any software support, no keyboard or mouse, it had Windows Pro 7 on it but it seemed corrupted (countless hangs on re-boot, post beep then nothing, lights on, nobody home etc). A Windows repair at the local computer shop fixed it but it died the next day again, I eventually got it to boot one time long enough to re-installed my own version of Windows 7 pro over what was there from the desktop (which kept the cool Alienware theme etc :)) however it would be good to know that if it goes titsup in the future I can just boot straight from USB or similar.

PS, should this happen can i get the cool X51 theme back?

PPS, the 1st X51 was sent GT 630 video graphic card, but it didn't boot, so they did a straight swap for another with more memory and a GT 555 card, can you advise if the replacement card is better/worse?

Dave

- - - - - Updated; Consecutive Post Auto Merged - - - - -

Well, I think I've sussed this, it appears that my plasma cannot show the BIOS screen due to the resolution, not sure exactly why, probably due to the low resolution output by the graphic card, this is a known issue on some graphic card/plasma's and can be worked around using a regular monitor to show the pre-boot screen.
 
Last edited: