test

ArmA 3 fps and video settings

Sleepy

Member
Joined
Feb 21, 2013
Messages
103
ArmA 3 Alfa seems to be giving most people computer a hard time :-( lol

So I thought I would share my specs and settings in the hope it may help others to get the game running good and if upgrading is needed , what would be best .

I'm using settings mostly , very high , with only 2 on high , and this is giving me a average fps of 47 ( which is actually a very stable 47 ) although the underwater parts I see a massive drop to 27 at places .... But surprisingly I'm not noticing the game play being bad in any way , if it wasn't for the figures in the top left of my screen I would know I was dropping frames .

So I'm happy with how this is running on my machin

Spec's of my machine are in my signature .

Hope this helps and please feel free to share what you guys are getting and on what ?

Thx
 
Joined
Apr 8, 2013
Messages
12
what are your specs i run arma 3 at 60+

3rd Generation Intel® Core™ i7-3770 (8M Cache, up to 3.4 GHz)
Windows® 8 Home Premium, 64Bit, English
16GB2 Dual Channel DDR3 SDRAM at 1600MHz
2tb harddrive
NVIDIA® GeForce® GTX 660 1.5GB GDDR5
 

Sleepy

Member
Joined
Feb 21, 2013
Messages
103
what are your specs i run arma 3 at 60+

3rd Generation Intel® Core™ i7-3770 (8M Cache, up to 3.4 GHz)
Windows® 8 Home Premium, 64Bit, English
16GB2 Dual Channel DDR3 SDRAM at 1600MHz
2tb harddrive
NVIDIA® GeForce® GTX 660 1.5GB GDDR5
Wow that is a nice fps :)

My specs are in my signature at the bottom of each of my posts : I'm running m18x i73940 oc @ 4.2ghz , GTX680 sli oc ,16 gb 1600 ram ,

What videos setting are you using to get 60fps + with that graphics card ?
 

Sleepy

Member
Joined
Feb 21, 2013
Messages
103
Although after some playing of wasteland arma 3 , Iv had to move my video settings down to , mostly " standard " and "high " this gives me a mostly stable above 30 fps but still with low dips for time to time .

Has any one got any tips for optimising my m18x fir this game ?
 
Top