test

ATA Vs AHCI sata mode

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,905
I am installing windows onto a single HDD. When I had it set up in RAID 0, obviously the SATA mode was set to RAID, when I had an SSD installed it was set to AHCI. I am wondering which is best to set it to when it's just on one HDD. AHCI or ATA? What is the difference? I'm leaning towards AHCI but I don't really know the difference.
 

AeonSoul

Member
Joined
Feb 21, 2012
Messages
1,367
I know AHCI works great for SSD, but I can tell you that my m17x R3 when it came with the factory 750GB HDD was set to raid. Don't ask me why, I have no idea.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,905
Well I can't even get windows to detect the HDD while I'm trying to install it. The HDD shows up in windows when I have the SSD in but once I remove the SSD and try to install windows, it says that there are no drives in the machine. I completely reformatted the HDD before it went in so I'm assuming it's missing drivers/firmware that it needs for using it as a boot drive. I installed the Seagate firmware from Dell but that made no difference. Maybe I didn't do it properly. It says, 'No signed device drivers were found. Make sure that the installation media contains the correct drivers.' I have used 2 different AW Windows 7 disks with the same result. Ahhhhhh!!!!! Someone help me!
 

Meaker

<b>Retailer</b>
Joined
Dec 12, 2012
Messages
43
AHCI is the best way to set it, you won't get the raid controller popup too which will make boot times lower.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,905
Nope. No luck. It still doesn't even give me an option to choose a disk like it does in these instructions. It's weird that it recognises the HDD when it is just the storage drive with the SSD but not when its installing. I have given up tonight and I will try again tomorrow. I'm thinking I may as well just sell it as it is with the SSD in it. I will need to do a fresh install on that disk too so I'm sure I'll have more problems with that.....
 
Top