test

Aurora R4 Mainboard won't POST.

Gadge Guru

New Member
Joined
Jun 3, 2017
Messages
2
Hi,

Does anyone on here know what could possibly be preventing an Aurora R4 Mainboard from successfully POST'ing and what things should be checked to try and fix the issue please?

Things that I've checked are as follows:

Tried two seperate ATX PSU's, tried known working CPU, RAM and GPU. Replaced thermal paste on AIO. These components have been borrowed off another Aurora R4 and are working okay on there.

Tried resetting BIOS (understand jumper needs to be put into reset position for 10-secs but do not know this for certain). Removed and replaced CMOS battery.

Notice that the fan that is attached to the heatsink on top of the VRM's spins upon powering up the Mainboard but stops after a few seconds and seems to try to spin (but stalls) but spins again after about 30-secs (possibly more).

With no AIO installed I've noticed that the CPU starts to get warm quite quickly therefore at a guess the CPU is getting power (don't leave switched on for too long though as don't want to destroy the CPU itself).

No idea what else there is to check to be honest. Already cleaned 'dust bunnies' from the Mainboard that were originally present particularly underneath the VRM's heatsink.

Unaware of whether there has been a failed BIOS flash upgrade on this Mainboard and cannot get any video to display whatsoever to try to get into BIOS nor diagnostics.

Would really like to get this up and running therefore would appreciate any help/suggestions on doing so. Thank you in advance.
 
Top