AW17 - Can't download World of Warcraft?

Sfynxx

Member
Joined
Mar 3, 2012
Messages
38
Hey guys! Long time, no see! :D

Okay, so I bought an Alienware 17 a couple of days ago and I can't download WoW. I have tried from the discs and from the website and nothing will work.. It comes up with an error code which links me to this battle.net site: https://us.battle.net/support/en/article/BLZBNTBTS0000F

It can't be a problem with my internet because my boyfriends works fine, from both disc and website client. And I have tried both sets of discs and still nothing. It's just on my computer that nothing will work.

I have absolutely no idea how to fix it and it's really beginning to bug me...

I tried downloading SC2 and it works fine, it just doesn't like WoW.

PLEASE PLEASE PLEEAAASSSE if anyone has any suggestions that could help it would be much appreciated! After trying for a couple of days already I'm about half a day from taking it back to the store.

:(
 

Sfynxx

Member
Joined
Mar 3, 2012
Messages
38
Can't install at all. It's coming up with all kinds of errors, like the one mentioned in the post and saying it's an incompatible program. I just got a friend to download it on his computer and I copied it onto a hard drive. It's working that way, thankfully. But yeah, no idea what was going on.
 

spacebooger

Member
Joined
Sep 10, 2013
Messages
54
maybe an issue with the drive you were trying to install Wow onto...but you werent having issues with any other games...weird, can you copy it over to the drive you tried installing it onto and see what happens?
 

forJAT

Member
Joined
Aug 7, 2013
Messages
163
are you running Windows 8? if you are then I would run the installer in compatibility mode. I have had to do that with a couple of my games. If that does not work I would lean towards something wrong with the disk drive. Are you running it on your C: or are you installing to another drive/partition? The game should install with the disks but without the updates required to play. Is it installing from the disk then failing when you you are updating?

Keep us posted.

Never mind you did. Glad it is working now :) I am going to think you had some interference when you were downloading the patches. All is well that ends well :)
 
Top