Battery Problem

Commy1

Member
Joined
Feb 25, 2012
Messages
325
So like any normal day I turned on my Alienware m14x and started playing a game (League of Legends) and whilst in the middle of kick some major ass... my computer just turned off.... The power cord came just a little loose and ping gone. So I think my battery is somehow disconnected, even though the laptop thinks otherwise.

Is this the only explanation or is there possibly a software issue? When I press the battery button on the bottom it reads full. And when I go to the desktop tool icon it says Fully Charged.

Someone help please? No point in having a laptop without the battery....
 

Commy1

Member
Joined
Feb 25, 2012
Messages
325
I have not disconnected it while running anything, kinda worried about it that's all. But without fail after Windows boots and desktop is loaded and I disconnect it shuts off and the power button won't turn it on.
I checked in the control panel what devices were installed/connected. The battery is on that list and the drivers are up to date.
 

Dantheman221

Member
Joined
Feb 9, 2012
Messages
563
Never heard of such an issue. Sounds like your battery just doesn't keep its charge. If your warranty is still active, you may want to be calling dell for a replacement battery. Make sure the battery is in the PC the right way. Sometimes, thats the problem :)
 

Commy1

Member
Joined
Feb 25, 2012
Messages
325
The problem just started though, I'd run the laptop on battery several times before.
 

Commy1

Member
Joined
Feb 25, 2012
Messages
325
Fixed it: Solution

Called Dell/Alienware tech support.
Rep told me to remove the back panel and take out the battery. Then to hold the power button for 2 minutes to drain the motherboard of power.
Then to replace the battery and turn it on with the Ac adapter, then disconnect the AC adapter.

The battery connection was probably just loose somehow, problem solved.
 

Dantheman221

Member
Joined
Feb 9, 2012
Messages
563
Told you, I thought you did the hard reset...Musta missed something xD Well, at least dell finally got their act together :D Hope you weren't talking to some indian xD
 

Commy1

Member
Joined
Feb 25, 2012
Messages
325
Told you, I thought you did the hard reset...Musta missed something xD Well, at least dell finally got their act together :D Hope you weren't talking to some indian xD
Aaron Fernandez...
I guess they've decided Mexico was a good idea lol... his accent was at least understandable.
 

Maelstrom

Member
Joined
Feb 25, 2012
Messages
698
Aaron Fernandez...
I guess they've decided Mexico was a good idea lol... his accent was at least understandable.
Well, that's closer to the problem than India. All I ever get are Indian tech support guys.
 

Commy1

Member
Joined
Feb 25, 2012
Messages
325
I guess I kind of have permission to go into the machine now without too much hassle from them for warranty.

I always wondered whether or not there was like a seal or something inside that would break if ever you opened the machine and that's how they'd know if you'd opened it or not after you send it in for warranty. Anyone know anything about that?
 
Top