Beware : New nVidia GeForce 320.00 crashed my M14x

Downloaded the latest driver 320.00 via GeForce Experience did an express installation, restarted and then..
NOTHING!
Got the windows 8 boot screen with the login and then back to boot screen endless cycle!!
I was thinking 'I've had this laptop for a week and I've already broken the thing!'
All I could to is an Alien Respawn and pretty much lost everything as I hadn't done a backup yet. Standard.
So hopefully you guys/girls don't experience the same!
 
Last edited:

sway

Member
Apr 12, 2012
676
0
Houston
Don't know if this was the problem, but never do express installation on drivers, especially display drivers. If you go to custom, then select clean, it'll get rid of the old driver while installing the new one.

tappin from the Note II
 

sway

Member
Apr 12, 2012
676
0
Houston
Maybe you had a bad download, I'd download it again off your gonna retry. This is a pretty good driver and adds performance pretty much everywhere, I had to even turn my core clock down a bit BC I was getting artifacts.

tappin from the Note II
 
Just did a clean install on my Aurora R4 and that crashed too?!
I reverted back to the previous driver and I am back to normal - I might wait until after beta release.
Probably wont take the risk on the M14x
Thanks everyone for all your tips!
 
Last edited:

Sleepy

Member
Feb 21, 2013
103
0
Uk
Don't know if this was the problem, but never do express installation on drivers, especially display drivers. If you go to custom, then select clean, it'll get rid of the old driver while installing the new one.

tappin from the Note II

I never new i could do this , thx for the info buddy , top tip , I think I will go back and redo it so it removed my old drivers as well