Bios Update A10 problem - Laptop takes 10-12 minutes to boot

Inso

Member
Apr 22, 2014
5
0
42
Lebanon
Hello,

Last night I downloaded a suggested upgrade to upgrade my bios to A10.
I downloaded the file from Dell's website, it updated from either A06 or A07 (I don't remember) to A10.
After that, Laptop either doesn't boot up, or just takes around 10 to 12 minutes to boot up.

Any ideas?

- - - - - Updated; Consecutive Post Auto Merged - - - - -

Quick update:

I tried to access UEFI bios from Windows (8.1), everything went fine, till laptop restarts to load bios, and never does, after like 10 minutes of inactivity it starts beeping (8 beeps, repeatedly).
I forced shut down, and on load Pressed F2, and was able to access the bios.
So I am guessing my motherboard is not broken (yet).

Any thoughts on how to fix this or downgrade back to the original bios?

Your help is highly appreciated.
 

Snowmerc

New Member
May 5, 2014
2
0
McHenry, IL
I had a similar situation with my Aurora R4 upgrading the bios. prior to the bios upgrade I was fully loading windows in about 1 minute, after the bios upgrade its taking 4 minutes. I thought the bios loaded fine but... I tried everything I could think of taking days of trying different things even a flash drive bios install. In my investigations, I found out bios cannot be back dated / install a lower version. I decided to contact Alienware Dell section... I was informed if the 1st attempt to upgrade goes wrong there is no way to fix it and he was talking about replacing the mother board. I then asked rather than replacing the motherboard what are my chances of upgrading to the next newest version and would this fix it? they stated its definitely possible, I asked how often do they come out, they stated 1 or 2 a year. I am waiting for the next version hoping this will do it. I will say that I made a bootable flash drive, I will upgrade my bios using this vs. the windows install version which caused my problem.
Just a thought.
Tom