Bricked m17xR2 after bios flash

Kazelone

New Member
Jan 13, 2016
3
0
Hello,

I wanted to flash my bios last night from A09 to A10 on my m17xR2. I downloaded the bios from dell drivers & download and extracted it. Then, I executed the executable inside it that had a similar name to the driver, since it had a self-extracting archive icon.

This was not a self-extracting archive, it was the utility to flash the bios from within windows. It started without asking me to accept or click anything, and I didn't want to close it since it had alrealy begun to write blocks. So I let it through, let it reboot my computer, and now my computer won't POST anymore.

The laptop still make the same HDD drives noises as usual, and the fan works as usual. Same for the LED's. However, there is no display. If I boot with a HDMI cable plugged in, I see it freeze at the bios screen on the secondary screen. It stays like that for a bit, then shut down (sometimes after a minute, sometimes after 5-10 minutes).

I tried to "blind flash" the bios. Since I'm on windows 8.1 on my other computer, I couldn't use WINCRIS. So, I made the drive a bootable dos drive through rufus, and put the bios on the root (tried several times, named the bios files a tons of differents filenames according to what I found on the internet), unplugged power cable, did a power drain, put the USB in the esata port, press fn+b, put power cable in, hold power for 3 sec then release power while holding Fn+B. No sign of activity. Sadly, my usb drive doesn't have any LED showing activity, but the computer did the exact same routine as usual and displayed only the alienware head with F2 and F12 on the secondary screen.

I also tried the same routine with Win+B, Fn+R, Win+R, Fn+F, Win+F, DEL and END keys.
I also tried to flash the drive with WINCRIS under windows xp sp3 compatibility modes (which I put on every other executables provided with WINCRIS.EXE in order to get it to boot) and it seemed to format my USB properly. Re-tried all of the above with no luck.

Tonight, I'll try to reset my CMOS, after getting the required tools on my way home.
Any other ideas? What's the proper procedure for blind flashing the m17xR2?