Dead M17x R5

Gavi

New Member
Joined
Oct 1, 2016
Messages
2
As the title says, my R5 has been dead for quite some time. The issue I am having is my computer doesn't want to power up. Plugging in the adapter turns on the lights to indicate that the computer itself is receiving a charge. Removing the battery and plugging the AC adapter back in results in no lights whatsoever. This happened completely out of the blue, where my computer just shut down and has been unresponsive. No amount of power button mashing seems to get this thing starting.

I have been over every possible solution I can think of, so if I missed anything please let me know.

Troubleshooting and "fixes" done:

-Removed adapter and battery, drained charge and replaced AC adapter (without battery)

-same as above WITH battery

-checked adapter to see if it was still functional

-also tried a separate adapter

-reset the cmos battery

-reseated the ram

-replaced the motherboard, despite my old one still working

-checked all cables, attachments, ribbons

-tried powering on the system after removing the nvidia graphics card

I feel I may be missing a few things I have tried, but these are the ones coming to mind right now. I have tried some of these multiple times to no avail and am really hoping someone has a solution. As I have said before, the only indication that the laptop is receiving power at all is the power button lighting up. Pressing the power button results in absolutely nothing; no fans spinning up, no screen attempting to turn on, etc.
 

Gavi

New Member
Joined
Oct 1, 2016
Messages
2
As the title says, my R5 has been dead for quite some time. The issue I am having is my computer doesn't want to power up. Plugging in the adapter turns on the lights to indicate that the computer itself is receiving a charge. Removing the battery and plugging the AC adapter back in results in no lights whatsoever. This happened completely out of the blue, where my computer just shut down and has been unresponsive. No amount of power button mashing seems to get this thing starting.

I have been over every possible solution I can think of, so if I missed anything please let me know.

Troubleshooting and "fixes" done:

-Removed adapter and battery, drained charge and replaced AC adapter (without battery)

-same as above WITH battery

-checked adapter to see if it was still functional

-also tried a separate adapter

-reset the cmos battery

-reseated the ram

-replaced the motherboard, despite my old one still working

-checked all cables, attachments, ribbons

-tried powering on the system after removing the nvidia graphics card

I feel I may be missing a few things I have tried, but these are the ones coming to mind right now. I have tried some of these multiple times to no avail and am really hoping someone has a solution. As I have said before, the only indication that the laptop is receiving power at all is the power button lighting up. Pressing the power button results in absolutely nothing; no fans spinning up, no screen attempting to turn on, etc.


I feel that I should also mention that I have tried removing all HDDs and SSD and attemptin to boot from a Windows HDD to another laptop I own to no avail.
 

Daddywoofdawg

Member
Joined
Nov 12, 2016
Messages
6
Do you get any beeps? if not replace your cmos battery,Is the cables connected from the Keyboard to the MB? for some stupid reason the M17x will not power on without the keyboard connected.I would say also check your power switch but you said your getting lights.
 
Top