Does x51 r2 POST or beep without GPU?

retr0ro3ot

Member
Joined
Dec 16, 2018
Messages
7
Hello
I have bought x51 r2 case from a reputable seller, and RAM and CPU from other reputable sellers.
I thought that it will work with onboard graphics. It does not.
When turned on, cpu fan is whirring, no post sounds and no beeps , Alienware head blinks yellow for one second and thats it.
Cpu fan whirs till I forcefully turn the pc off. It behaves the same without memory installed.(thought that without memory it will at least give me beeps)
I have tried resetting the BIOS with the jumper.
So either I bought defect CPU or defect alienware MOBO, or it does not work with integrated onboard graphics by default ?
 

k9charlie

New Member
Joined
Dec 15, 2018
Messages
2
I am having problems in a r1 that won't start. What I can tell you is that if I do not have the RAM in, then I get the characteristic 2 beep POST code letting me know there is a RAM issue, so you are right that it should beep without RAM. Sorry I can't be of any more help.

Obligatory questions posted on other threads.
  • Have you tried unplugging everything?
  • Are you sure the PSU is working properly?
 

retr0ro3ot

Member
Joined
Dec 16, 2018
Messages
7
Yes, I have tried unplugging everything, and regarding the PSU, I have no way of testing it (meaning like checking voltage delivered).
I am getting discrete GPU possibly tomorrow so I will see what happens.
It seems that r2 does not have an integrated speaker.
 

retr0ro3ot

Member
Joined
Dec 16, 2018
Messages
7
Discrete GPU is here, unfortunately, same happens...
It seems like the cpu is dead, but the heatsink gets warm a little.
 

MattyB

Moderator
Staff member
Joined
Mar 19, 2012
Messages
2,707
You should get a beep code if the CPU has an issue. I bought an R2 from an auction site a few years back. It wouldn't start either and I realised that the CMOS battery wire was broken (along with the wifi cables), probably when someone tried jamming the GPU in it. Just check over every wire you can find to see it's all good. It's pretty tight in that case.
 

retr0ro3ot

Member
Joined
Dec 16, 2018
Messages
7
Thx...i have also bought it barebones from repitable seller who said it works
Meanwhile i have found out that it does have an mobo speaker so it should beep.
Cpu is i5 4460 maybe bios upgrade was not done so it does not recognize it?
I have bought pentium g cpu to try it also it will arrive tomorrow.
I will remove wifi msata card , and try
It doesnt seem broken though
 

retr0ro3ot

Member
Joined
Dec 16, 2018
Messages
7
No, just MOBO, with msata wifi card and thats all.
I have GPU CPU RAM and SSD.
I have no progress here, no sounds, like MOBO is dead, or CPU. :/
 

MattyB

Moderator
Staff member
Joined
Mar 19, 2012
Messages
2,707
Dead mobo would be a pain but you can get them for less than $150 off Aliexpress. If the computer hasn't been used for a long time don't count out the CMOS battery. They can cause a failure to boot if they are dead. They last about a year without power.
 
Top