Does your Alienware 17 run like this?

Santo

Member
Joined
Feb 4, 2014
Messages
6
I've had my laptop for a while now, and I just cant seem to understand lag sometimes.
For example, the day I got it, I was getting excess of 60 fps at max graphics in Assassin's Creed III, now I can only get 60 FPS when running at 720p, instead of 1080p and even then I get microstutter.

Also, some games run flawlessly then seem to have fps drops at seemingly random times.
For example running Bioshock infinite will give me 60 fps and then drastically drop down to 20-30 and then back up again. (this also happens in Grid 2)
Would a factory reset fix this issue?

Im running an Alienware 17:
8gb RAM
i7 2.4Ghz
GTX 770m

- - - - - Updated; Consecutive Post Auto Merged - - - - -

Bring
Up
My
Post
 
Last edited:

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,992
Have you updated your NVidia driver since you got it?
Also, if you have it in an area which has a lot of fluff, dust, pet hair etc, your fans and heatsink may be a little blocked. This could cause performance issues if it's heating up.
 

Keeps

Member
Joined
Dec 20, 2013
Messages
35
You could check the temperatures with free software. Can't remember the name of the program I use but google should know it if you search Free GPU temp monitor.
 

Santo

Member
Joined
Feb 4, 2014
Messages
6
My room is a little dusty and am in Australian summer :L
I have updated nvidia driver like the second I got it :L
I will try these thanks!
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,992
I posted a thread here somewhere a while ago showing the insides of a mates M17x which had become seriously blocked up with fluff. It caused his GPU to overheat and fail. Dell replaced his machine which was good but it showed that regular maintenance is necessary.
 

Santo

Member
Joined
Feb 4, 2014
Messages
6
I only got my laptop on the 7th january. there shouldnt be any blockage what so ever
Honestly, should I be seeing ANY screen tearing or micro stutter EVER? Do you get these problems on YOUR alienware 17?
 

sway

Member
Joined
Apr 12, 2012
Messages
676
Turn on v sync in video settings to stop screen tearing, if your getting fps drops you might need to turn down video settings on some games bc they're pretty demanding and that gpu might not be able to handle it. You could also be running out of vram which is causing the fps drops.

tappin from the neXus 5
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,992
Yeah you shouldn't be having too many problems at this stage. I am getting some tearing though on my custom desktop though at the moment which is water cooled. Seriously hot days though recently which would explain that. Damn Australia!!
 

krazor8

Member
Joined
Jan 29, 2014
Messages
6
i have the 17 with the r9 m290x... i have the same problem but it only surfaces if i unplug my laptop and plug it back in.. the clocks for the gpu get stuck at battery settings and wont move up, there for i have to play assassins creed at 720p or lower
 
Top