test

Fallout 3

cmaesing

Member
Joined
Apr 29, 2015
Messages
5
Received my 1st Alienware ever last week. Finally!

Getting it all set up is still taking up time. One step after another! After having successfully transferred FS9 (FS 2004 Flight Simulator) with all addons from my old pc, I wanted to install Fallout 3 GOTY (UK dvd edition, not Steam version) last night. Unfortunately, to no avail.

I did read through many different internet forums (e.g. Steam) and attempted to fix it with the suggestions made here and there:

1. Running under XP SP3 compatibility mode.
2. Running as admin.
3. Installing Fallout 3 in a directory different from 'program files' or 'program files (x86)'.
4. Adjusting the fallout.ini file (as found under 'documents - my games - Fallout 3'.
5. Attempted to install or uninstall Microsoft Games ... (cannot remember the exact name now) program. I might have not done this 100% correct - but am actually not sure I even installed the right program (which I downloaded from the Microsoft webpage).
6. Adjusting under 'options' on the Fallout 3 start screen the settings (windowed, low graphic settings etc).
7. Aligning the game's screen resolution with my desktop's.

What I did NOT do yet is adjust the BIOS upon startup (that was 1 suggestion in a forum, but I am not sure I want to give this a try).

...

The bottom line:

When I run Fallout 3 now, the initial start up screen shows. However, when I click 'play', it attempts to run ... there even is for a fraction of a second a (it seems graphics related) message in the icons area of the task bar. But this message appears only for such a short time that I cannot even faintly read it. And then the start up screen just shows again! So I'm ultimately moving in circles.

...

My high level specs:

17 R2 970M
W7 64

Fallout 3 is (without the 2nd dvd from the GOTY edition ... wanted to get it to run in vanilla 1st) installed on my laptop's hd (in 'c - games').

Fallout 3 did run on my old pc (W7 32, much less capable than my new Alienware) without any issues whatsoever! Which is why I was so hoping to be able to enjoy Fallout 3 now to its fulles with all the main mods!

Anyone? Thanks!
 

cmaesing

Member
Joined
Apr 29, 2015
Messages
5
R E S O L V E D !!!!!

...

I think I spent minimum 24h straight installing, copying, pasting folders, deleting, renaming, patching, uninstalling ... plus countless of hours in various forums discussing (a) Fallout 3 not running under W7 64 at all, or (b) freezing during the intro scene ('baby scene' ... a few moments after you choose the gender of your character), or (c) crashing to desktop upon saving a game while in game.

Here is what I did (and what I deliberately skipped), and what finally got my game running:

====================

1. Freshly install GOTY (UK DVD version) with all DLCs. On purpose I neither used the 'Program Files' nor the 'Program Files (x86)' directory for this.

2. Install the unofficial patch 1.8.

3. Did NOT install a single mod.

4. Did NOT disable 'Games for Windows Live' (as I like to keep my achievements).

5. Run both the Fallout3.exe and the FalloutLauncher.exe under (a) XP SP 3 compatibility mode, (b) as admin, and (c) with 'disable desktop composition'.

6. Ensure to adjust the file '...\My Games\Fallout3\FALLOUT.ini' as per countless recommended forum posts across the entire net. Example page: http://steamcommunity.com//sharedfiles/filedetails/?id=149946772 (see under #4 there).

7. Added the file 'd3d9.dll' to the Fallout 3 installation folder (the one where e.g. the Fallout3.exe file is located). And ran the FalloutLauncher.exe thereafter. The launcher recommended medium high settings - I left it at that (knowing I'd, once the game is stable, be able to play with the graphics settings). For me, the 1st dll file of the 2 offered here did the trick: http://www.nexusmods.com/newvegas/mods/34778/?tab=2&navtag=http://www.nexusmods.com/newvegas/ajax/modfiles/?id=34778&pUp=1

8. Ensure that the game screen resolution matches my desktop's (1920:1080).

9. Set the affinity (in the task manager, after having started up Fallout 3) of the Fallout3.exe to only a single CPU. I chose CPU 0 (out of a possible 8 that I could choose from). But my guess is that you could choose any of your CPUs here. I am not an expert, but it seems this has to be adjusted every time Fallout 3 runs. And it might actually be (and I'll make sure to test this) that this measure is not even required after all ...

10. When in game in Fallout 3, I disabled all 3 autosave options (via 'settings', then on to 'gameplay').

The combination of all these did NOT yet get me beyond the intro screen freeze (baby scene).

====================

However, what DID finally help was this last step:

11. Per suggestion in one YouTube video, I increased the attribute 'actor fade' in the options menu. It was at the lowest (possibly automatically set through the FalloutLauncher.exe), i.e. leftmost level. I increased it to the middle, just to be safe restared the game - et voilà: All running nice and smooth!


And that last and 11th step finally got me beyond the screen freeze - and into the actual game! No crashes so far, keeping fingers crossed. I am not an IT expert, so am unable to say whether it is #11 alone, or a combination of only a few of the aforementioned measures ... or possibly all of them that helped.
 
Last edited:
Top