test

FPS low when I turn on M18x, fine after restart

xI WeLLs Ix

Member
Joined
Mar 5, 2012
Messages
24
When I turn on the M18x and load up a game, fps is really low until I restart the machine. I don't know what is causing this. Seems to be fine on 1 GPU but not on SLI - 1 GPU is near 100% usage and the other about 20%.

Things I have tried:

Original OS (Windows 7) - I'm no on Windows 10
Different GPU drivers
Blown any dust off SLI connectors
Reflash BIOS
Reflash VBIOS's - they are on stock clock speeds
Switched to Integated Graphics (HD 3000) then back to GPU's (2 GTX 580M's)
Unplugged everything
Holding the alt key when I turn the machine on and run the Hardware Assessment, to which it passed.

Heat is not the issue as I've only just turned the system on. Also I can play hours on end with no fps drop.

I used Call of Duty Black Ops main menu for my test. I should get 40fps in the menu but I get between 6 and 14 fps. After restart, I'm back to 40 fps.
 

Attachments

  • Before Restart 1.jpg
    Before Restart 1.jpg
    944.8 KB · Views: 2
  • Before Restart 2.jpg
    Before Restart 2.jpg
    833.1 KB · Views: 2
  • After Restart.jpg
    After Restart.jpg
    971.6 KB · Views: 2

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,961
Almost sounds like your machine thinks it's running off the battery instead of the power brick. It's a bit hard to work it out without the machine in front of me. Sounds like you've tried just about everything. Have you tried changing your power settings or doing a battery drain? Simple things I guess but you never know.
 

xI WeLLs Ix

Member
Joined
Mar 5, 2012
Messages
24
Just pulled off the battery and left the machine off for a while, turned it on and I've got low fps again! Seems like something is not right when the machine starts up but is fine upon a restart?

This started a few months ago when I was on Windows 8.1 connected up to an external TV and Surround Sound System via HDMI. Since then, I got a desk so I'm not connected up to any external devices, I'm on a fresh install of Windows 10, partitioned my drive and put Windows 7 on it, to which all have the problem.

I shall do a static discharge on the laptop and power supply whilst the battery is off now and I will report back later if it worked or not.

Many thanks for your help, it is much appreciated!
 

xI WeLLs Ix

Member
Joined
Mar 5, 2012
Messages
24
Okay so I set forced the game to load without SLI and FPS is much higher than it is with it on! I mean the difference here is with it off I hit 60fps but with it on I get about 14fps... GPU1 at 20% utilization and GPU2 at 90% utilization. Could this be an issue with SLI not being initialized properly on boot or a GPU slowly dying?
 

xI WeLLs Ix

Member
Joined
Mar 5, 2012
Messages
24
Sorted it! I took the whole laptop apart including the CPU and GPU's, blowed out any dust, cleaned off SLI connectors and put it all back together. Works perfectly now!
 

JediFonger

Member
Joined
Jul 31, 2017
Messages
15
DUST is a huge killer! but once you fix dust:

priority of performance enhancements (where you ought to spend $ from top to bottom):
1. SSD
2. GPU
3. RAM
4. CPU
 
Top