test

gpu dosn't run games

illyrius

New Member
Joined
Apr 16, 2013
Messages
1
Hi! I have some problems with my gpu. It doesn't seem to run games. I have changed in NVIDIA control panel so they should start automatically with the gpu, I also right clicked on the .exe file and chose "run with high-performance NVIDIA processor". But nothing comes up in nvidia activity window. I tried running 3dmark and that uses the gpu. The power settings is set to high performance.

Any idea what to do?

Games tried:
Crysis 3
skyrim
COD MW2

M14x R2
i7-3630qm @2,4
gf 650m, 2gb
8gb ram
500gb hdd
win7
 

Commy1

Member
Joined
Feb 25, 2012
Messages
325
All I can suggest is a clean driver install.
Go to nVidia.com, download the latest drivers, do a Custom install and select everything you want, it will wipe whatever settings you have and start over. If that doesn't work come back.
 

AeonSoul

Member
Joined
Feb 21, 2012
Messages
1,367
I'm gonna ask a silly question: have you tried to run the game? If so, do you experience FPS loss?
 

Sleepy

Member
Joined
Feb 21, 2013
Messages
103
Here another simple thing I'm hoping you have tried , try running it plugged in.

This will give you a gpu boost ,even after you have set it to power performance .
 

BlackJair

Member
Joined
Mar 8, 2012
Messages
340
I had the same problem, but it was because a Install failure(Of the game) Because I was able to run MW3 but not MW2 and many other games(Such as Crysis 2 and Skyrim) were blurry at times.
 
Joined
Aug 10, 2012
Messages
163
I had similar problems..
In device manager make sure the intel HD4000 graphics card is not disabled!
Mine was out of the box!
Hope this helps
 

AeonSoul

Member
Joined
Feb 21, 2012
Messages
1,367
Oh yeah and ofc, plug the power chord in and set your laptop to run in high performance.
 
Top