test

Graphics performance lag

ArnoSwart

New Member
Joined
Jun 6, 2013
Messages
1
Hi,

I'm having trouble with my laptop's performance when it comes to playing games. I have a gtx675m graphics card, 12gb RAM, i7-3720QM running windows 8. When I play any game (Far Cry 3, Darksiders, Bioshock, Dishonored) it lags extremely bad even on the lowest settings. I should be able to play these games easily on this computer. Any ideas what could possible cause the lag
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,918
Welcome! There are a few things you could try. You can make sure your NVidia driver is up to date. Go to www.nvidia.com and follow the prompts for installing the latest driver. Then you need to make sure that your machine is running the games on the Nvidia card and not the intel graphics. Right click on your desktop and go into the Nvidia control panel. Go into Manage 3D settings. There is a tab there that allows you to run programs using the Nvidia card or the built in graphics. If your games aren't listed you can find them using the prompts on that page somewhere. Sorry I'm away from mine at the moment so I can't be specific. Hopefully that fixes it for you!

- - - - - Updated; Double Post Auto Merged - - - - -

When you're in the 3D settings page go into Program Settings. That's where your individual games should be. If you press 'Add' you can find any games not listed. From memory you may have to go into the game folder and find the Application file of the game or maybe the file ending in .exe. Something like that anyway.
 

jorlanm

Member
Joined
Jun 22, 2013
Messages
58
Hi,

I'm having trouble with my laptop's performance when it comes to playing games. I have a gtx675m graphics card, 12gb RAM, i7-3720QM running windows 8. When I play any game (Far Cry 3, Darksiders, Bioshock, Dishonored) it lags extremely bad even on the lowest settings. I should be able to play these games easily on this computer. Any ideas what could possible cause the lag

Are you playing in Battery? If you are then youll have lag...also check if your using the Intel graphics instead of the NVidia...
 
Top