Hello!

KuRialv

Member
Joined
May 3, 2012
Messages
9
Hi guys! I bought an alienware x51 desktop with the highest spec, i7, gtx555 about 2 weeks ago and i just got it today. This is my first AW system and my first gaming system actually and i really excited about it. btw i'm from Malaysia but currently staying in Canada for studying. Anyway, i hope you guys can help me since i'm a noob in computer. i think that's all. thanks.
 

Jenova

Member
Joined
May 2, 2012
Messages
104
Welcome to the club, I also bought an x51 and it's an amazing piece. Playing wow on ultra settings at 60fps. I'm sure it could go higher too if I didn't keep the refresh rate at 60. Coupled with a 23" led 1080p monitor it looks good too! Can't wait to test it on d3, interested in seeing how well it handles something my old computer crapped out on.
 

KuRialv

Member
Joined
May 3, 2012
Messages
9
Do you have any problem with the wireless? Mine keep disconnecting every few minutes and it is very annoying. Luckily i got an usb wireless adapter from my previous system.
 

EMT911inWI

Member
Joined
Feb 21, 2012
Messages
98
Welcome to AWO. If you have any questions or problems please feel free to speak up. A lot of knowledge floating around here!
 

AeonSoul

Member
Joined
Feb 21, 2012
Messages
1,380
Welcome!
I'm pleased to see people satisfied with their new purchases :D
About the x51 wireless I've read a couple of people with the same problem as yours, maybe you should try to browse around the forums here or google it!
 
Top