intel HD 4600...or 770m?

i have my computer loaded into the 770m gpu...but for example i use passmark to bench it shows the intel HD 4600 but not the 770m and the graphics are horrible...help?

- - - - - Updated; Consecutive Post Auto Merged - - - - -

ok something is very wrong it scored a total score of 636...??

- - - - - Updated; Consecutive Post Auto Merged - - - - -

the only thing that scored well was the SSD which i installed
 

shankc

Member
Dec 26, 2012
407
0
UnitedKingdom
Hi spacebooger nice score, are you using a beta driver or it could just be with it being a new card. Have a check of what scores other people are getting and if it is recognising their drivers. Its nothing to worry about,let me no how you get on because it's not all about benchmarking. If it plays the games you enjoy which it should that's what counts. Have fun and game on and if you run into anymore problems their is always someone on here that can help
 
Hi spacebooger nice score, are you using a beta driver or it could just be with it being a new card. Have a check of what scores other people are getting and if it is recognising their drivers. Its nothing to worry about,let me no how you get on because it's not all about benchmarking. If it plays the games you enjoy which it should that's what counts. Have fun and game on and if you run into anymore problems their is always someone on here that can help
Not worried about its benchmark...aslong as it wasnt benchmarking like it was when i ran passmark...ever again...not sure what went wrong exactly for it to get a 636 overall but now its getting a 3400, i i was comparing it to my previous laptop the g53sw which had the gtx460m 16gb ram and the intel 2630, so when it scored so badly...like less then generic i had to get down to it lol