test

Jumpy Trackpad with 2-finger scroll

Sting_NC_USA

Member
Joined
Feb 7, 2015
Messages
9
Hello,

On my new AW 17 R2, when I start to scroll in either of my browsers (IE and Chrome) the instant I put my two fingers on the touchpad and begin to scroll, a little white square appears for a second then it starts to scroll. I've since figured out that touching the mouse pad with two fingers then using a very slight movement causes a "right-click" action bringing up the properties menu. There's a white box animation that starts before the properties menu opens, or if you continue to scroll the little white box simply goes away, and the screen scrolls.

On most systems a two finger tap, or right-click engages the properties menu. On this one, it requires a two-finger tap, then a slight movement of your two fingers. The current drivers don't have that functionality listed as assignable, and I'm wondering if that may be causing the main issue I'm writing about today.

The issue is that when I scroll quickly, often times the web page will shoot all the way to the top, or bottom, depending on the direction I'm scrolling. Sometimes the browser (both IE and Chrome) will shoot to the top or bottom then "bounce" back to a random position.

Seems like a driver issue, as every time I go to two finger scroll, the little white box animation described above appears just for a millisecond before the screen actually scrolls.

For the record, I've disabled the inertial scrolling feature, as that works terribly on my system. With that on, a quick scroll causes the scrolling feature to bounce back and forth (up and down) as if I'm shaking the screen.

Sorry for the long description, though any assistance would be very much appreciated. There may be another driver out there (possibly for an older Alienware system) that offers more stable functionality, and possibly more features than the default driver.

Thank you!

Michael
 

ccc

New Member
Joined
Feb 28, 2015
Messages
1
I have the same issue on my Alienware 15, however it's only an issue in Chrome. IE scrolls fine. I tried downloading the input device driver update from Dell's site, but it didn't help. I absolutely need to use Chrome, and these squares and jumpy scrolling makes it unusable.
 

Sting_NC_USA

Member
Joined
Feb 7, 2015
Messages
9
I now have my replacement Alienware 17 and the issue with Chrome still exists. I've scoured the web and the advanced settings in Chrome for a solution with no luck. The issue clearly has something to do with two finger scrolling causing the properties window to pop up. Dell's driver doesn't seem to have a two-finger tap feature that causes a right-click action, and I can't find a way to disable two-finger tapping in Chrome. Very frustrating. Anyone else running into the issue, or possibly run across a fix?
 

Sting_NC_USA

Member
Joined
Feb 7, 2015
Messages
9
Great start, barezb, after testing a bit on the Alienware 17, the proposed recommendation gets us very close. On our systems, there's a few more steps needed.

For the record, I'm not trying to take credit for this fix, but rather sharing what I found here and there so that you don't have to read all of the various websites that lead to this find:
  • Before you start, visit the Synaptics website and download their latest driver. Don't run it yet, it will fail.
  • Set a System Restore point, for safe keeping, and proceed with the following at your own risk. I will accept no responsibility for anything that happens to your system.
  • Next, go to the Control Panel to the Uninstall Programs option and uninstall the Synaptics entry. (I didn't restart here.)
  • On your keyboard, hold the WIN key and the letter i (WIN + I)
  • Left-click "Change PC Settings"
  • Left-click "Update and Recovery"
  • Left-click "Recovery"
  • Left-click "Advanced startup" then left-click "Restart Now"
  • After reboot, left-click on "Troubleshoot"
  • Left-click "Advanced Options"
  • Left-click "Startup Settings" and click Restart
  • After rebooting, a blue screen comes up, press 7 to select "Disable driver signature enforcement"
  • Install the Synaptics driver you downloaded above by right-clicking on the setup.exe file and choose the "run as administrator" option
  • Restart the PC after installing the driver.

For me, performing the above steps resulted in a pop-up stating the driver installed successfully. But, I couldn't access the Synaptics Settings, and only the standard mouse settings were available. And, as you might expect, without the right software, the mouse functions poorly. Here's the part that was missing, and worked for my system:
  • Open your Control Panel, then the Device Manager
  • Locate and expand the touchpad device to reveal the “PS/2 Compatible Mouse”
  • Right-click on the PS/2 device and left-click “Update Driver Software”
  • Select “Browse my computer for driver software”
  • Select “Let me pick from a list of device drivers on my computer”
  • Uncheck the option “Show compatible hardware”
  • Under “Manufacturer”, scroll down to “Synaptics”
  • Select the driver that shows in the right portion of the window and Left-click "Next."
  • Click “Yes” to the “Update Driver Warning” pop-up.
  • Restart

As mentioned, upon reboot, I had a menu pop up asking me if I wanted to use the unsigned driver, or something to that effect. I can't validate if this truly utilizing the newest version of the Synaptics software; however, everything now now seems to be working.

You will likely need to tweak the Synaptics software to your preference. For my system, I had to immediately turn off inertial scrolling, while also turning down the speed of scrolling a bit. You can now reverse scroll, or not if you choose. Simply dive through the settings and update to your individual preference. I also believe there's a way to enable two finger tap for the right-click properties window (via a registry change), though I'll research a little more and then post if it works.

It's possible that each of the above steps may not be needed, but it's what I did and it worked.

Good luck, and feel free to post tweaks and other updates that may better clarify the above. All I ask is that, if you update the above, please re-post the full process you've devised so people don't have to piecemeal what does and doesn't work.
 
Joined
Jun 27, 2015
Messages
8
im having pretty much the exact same problem only without the squares. i have to 2finger scroll really slow or it shoots to the bottom or top of the page. so annoying. ill check out that solution you posted.
 

Zane

New Member
Joined
Jul 22, 2015
Messages
1
I have had this problem for so long, thank you Sting_NC_USA. Your solution was easy and worked perfectly, I only wish it was easier to find when looking stuff up on this issue.
 
Top