liquid gpu upgrade area 51 r2?

311Taking

New Member
Joined
Mar 1, 2016
Messages
2
hello everyone new here and have a question. i have an alienware area 51 r2. just got a titan x. i have a 850w power supply is it possible to liquid cool the gpu? also on the 850w power supply is it enough to sli the titan x?
 

Cass-Olé

Member
Joined
Jan 9, 2013
Messages
249
we saw @AlienAndy drop a pair of gpu koolers in his R2: My rigs
@W8lifts says this about 980Ti SLI: 'the 980ti's in SLI seem to be just fine with a 850 watt PSU. Was a little surprised that the PSU could handle the load'. He did drop in a 1000w eventually. TX & Ti are rated at the same 250w tdp, so I'd say, try the 850 you have - if it shuts down - put it in your budget for something 1kW or better.
 

311Taking

New Member
Joined
Mar 1, 2016
Messages
2
we saw @AlienAndy drop a pair of gpu koolers in his R2: My rigs
@W8lifts says this about 980Ti SLI: 'the 980ti's in SLI seem to be just fine with a 850 watt PSU. Was a little surprised that the PSU could handle the load'. He did drop in a 1000w eventually. TX & Ti are rated at the same 250w tdp, so I'd say, try the 850 you have - if it shuts down - put it in your budget for something 1kW or better.
awesome thank you very much. ive looked all over the place for the 1500w power supply from dell and cant get it what power supply could i get that would be a straight swap
 

Cass-Olé

Member
Joined
Jan 9, 2013
Messages
249
the part# for the 1500w / 1440w 12v max Delta is 0800GY (aka 800GY). Chat with Dell again using that part#.
Gaudio (ax1200i), Mark (EVGA 1600G2) & W8 (Rosewill & ax1200i) tried to install a new psu, but the system did not turn on; that either means user install error, a DOA chassis, or a finicky R2, I wish I knew. On the other hand, here --> Gman (ax1200i) W8 (EVGA 1000), SJ (EVGA 1300) & AlienAndy (ax1200) did pair new psu's either with the stock mthrbrd in R2 case, aftrmrkt mthrbrd in R2 case, or stock mthrbrd in a new case; in all three scenarios a psu worked with the original equipment, whereas other owners had an issue of unknown origin. I'm using the 1500w Delta, so I can't say which is best. Buy yours from a place that accepts a hassle-free return. Never re-use the stock case harness, only use the cables supplied in your new pouch. Wait for others input ...
 

Kanes_Inferno

Member
Joined
Jun 12, 2014
Messages
56
the part# for the 1500w / 1440w 12v max Delta is 0800GY (aka 800GY). Chat with Dell again using that part#.
Gaudio (ax1200i), Mark (EVGA 1600G2) & W8 (Rosewill & ax1200i) tried to install a new psu, but the system did not turn on; that either means user install error, a DOA chassis, or a finicky R2, I wish I knew. On the other hand, here --> Gman (ax1200i) W8 (EVGA 1000), SJ (EVGA 1300) & AlienAndy (ax1200) did pair new psu's either with the stock mthrbrd in R2 case, aftrmrkt mthrbrd in R2 case, or stock mthrbrd in a new case; in all three scenarios a psu worked with the original equipment, whereas other owners had an issue of unknown origin. I'm using the 1500w Delta, so I can't say which is best. Buy yours from a place that accepts a hassle-free return. Never re-use the stock case harness, only use the cables supplied in your new pouch. Wait for others input ...

Seems that power supply is tough to find. I've been looking at a potential Area 51 with the 5820k and would want to upgrade the power supply later, since the site doesn't have that option (it's from a site other than Dell).. I chatted with Dell today and the part is out of stock. I can't find that part in stock anywhere... Now I'm second guessing ordering that Area 51 :(
 
Top