M17x R3 Battery plugged in, not charging

Brrandon

New Member
Joined
Sep 3, 2013
Messages
2
Hello Alienowners,

I have a problem with my M17x R3 regarding the battery and the AC adapter. Since yesterday, whenever I plug in the power it gives me this error:

The AC acadapter currently connected is not supported. System will continue on battery. Press any key to continue.

The battery won't get drained, but it also won't charge. It is at 63% now, but if I continue to use it without it plugged in it will drop more and more.

I have tried these things to get it fixed but they don't work for me.

  1. Updating my bios to A12, which helped this person.
  2. This solution where you remove the battery and the AC adapter and press the power button for 10 seconds.



It's a shame this suddenly happened. I already had a Dell-support tech replace a broken fan last year (just before my warranty ran out). But I'm afraid they'll have to replace the motherboard and I'll have to pay a shitload of cash.

Hope you guys can help me out.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,992
I don't think you'll have a mobo issue. It will either be the battery or the adapter. I would start by trying to find someone who has a similar adapter to see if it works. If that doesn't work then grab a new battery from eBay for $70-$100.
I have heard that there is a very small part inside the adapter and if it gets a big enough whack it will break and cause this problem. It's the best place to start though
 

BrokeHombre

Member
Joined
Apr 15, 2013
Messages
80
It is more than likely the adaptor - I had the same issue right after I got my AW - actually my office ordered 3 AW M17xR4's and each one had to have the adaptors replaced with the big brick ones. Ours were under warranty of course, hate to see what the cost was for these super powered adaptors!
 

Brrandon

New Member
Joined
Sep 3, 2013
Messages
2
The blue light of the adapter is still working so I assumed it was working correctly.

I ordered a new battery from ebay for 100 euro. It was delivered today but it was no use. I still got the same problem.

I'll have to call tech support to fix this for me I guess..
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,992
I still think it's the adapter. The light just means that it's getting power through. I hope you can get it sorted soon!
 

shankc

Member
Joined
Dec 26, 2012
Messages
407
Yes I agree with Mattyb definitely sounds like the adapter if you know anyone with the same or even if its off another dell laptop doesn't have to be an alienware adapter like an xps or inspiron they won't have the power to run your system but at least you'll be able to check before spending more money
 
Top