M17x R4 Keyboard Not Working In BIOS

Octeract

Member
Dec 29, 2021
5
0
US West
I'm at my wit's end with this one. As the title says, my M17x R4's keyboard is not working in my BIOS, both in the setup and in the one-time boot menu. This also includes Windows startup repair (when accessed at boot), GRUB, and GRUB-based installers. I can still use CTRL+ALT+DELETE to exit the BIOS and force a restart, but that is it. Nothing else works. The keyboard is perfectly functional inside of Windows, various Linux distros, and even on disk encryption unlock pages for every distro I've tried. Interestingly, my keyboard is also fully functional inside the diagnostic tool included with the BIOS, which is accessible from the one-time boot menu. I've been using a USB keyboard to navigate my BIOS for the time being, but it has been annoying to get out and use when I have a perfectly good one built into the machine.
Note: When I write "BIOS," I mean "UEFI BIOS." Not even when flashing other BIOS versions have I gone into the realm of a non-UEFI BIOS.

Let's look at some troubleshooting that I've done (skip if you just want to see my final lead):
  • I have tested some likely (and unlikely) settings and have failed to find anything that enables the keyboard inside the BIOS.
  • I have flashed every version of the BIOS that I can from Dell's available downloads (A5, A8, A9, A10, A11, A12, A14, and A15; A2 does not flash, maybe because it's non-UEFI and therefore can't downgrade). The keyboard's functionality does not change for any of them.
  • I have removed my CMOS battery and discharged any remaining electricity a few times to try to resolve this problem. None were successful. On my last unsuccessful attempt, I left the battery out for over an hour (the main battery and AC were both removed) and I held the power button down for minutes at a time at several points during the period. Some settings were reset, but the keyboard's behavior remained the same.
  • I replaced my keyboard entirely. This was related to keys dying on the last one, which culminated in the backlight ribbon cable severing while I was attempting to improve the connection of the main ribbon cable to the connector on the board (cleaned with alcohol and blew with canned air). Both cables were probably just overworked, so I ordered a new keyboard. I researched thoroughly beforehand and saw that there were a few different versions of the keyboard floating around. I found a recent thread where someone was having trouble with the same keyboard I had. The original poster tried replacing a new version (Windows 8 logo) with the older version (Windows 7 logo), but the replacement was not working at all (probably just dead on arrival). Hoping that this was a lead, I ordered the version with a Windows 8 logo despite my original keyboard having a Windows 7 logo. The new keyboard works perfectly, but the BIOS is still not responding to it. My old keyboard's part number is PK130MK1A00, and my new one's is PK130MK1B00. Here is the thread I mentioned:
    http://forum.notebookreview.com/threads/m17x-r4-doesnt-respond-to-new-keyboard.837083/
  • One of my friends mentioned that my keyboard might be in NKRO mode. NKRO, or N-Key Rollover, is a feature of mechanical PS/2 keyboards that allows users to press every key on the keyboard at the same time and have the inputs all register correctly. NRKO sometimes confuses a system's BIOS, making it unresponsive to the keyboard. Seeing as my keyboard appears in Device Manager as a PS/2 keyboard, I thought it might be remotely plausible. Upon further research, however, it appears that users have complained about the M17x R4 not being able to register very many simultaneous keyboard inputs, thereby causing problems in games. I have personally hit limits on occasion while gaming, so NRKO cannot be the issue. Just to be sure, though, I looked all over the keyboard and motherboard carefully for any kind of switch that could toggle key rollover. I found nothing. I also reviewed what the function keys do and again found nothing related to key rollover or key ghosting (another item related to key rollover).
    Note: For the sake of this post, I glossed over some details of key rollover. More info is available in this video and on multiple articles available with "NKRO" as a search term:
    https://www.youtube.com/watch?v=kOkV9BalNcw
  • Dell has no keyboard drivers for the M17x R4. The only driver with "keyboard" in it is the touchpad driver, which I have had no issues with.
  • Uninstalling the keyboard in Device Manager does not change anything.
  • I set the service tag and admin password. My service tag sticker wore off, so I just entered 0000000 to see if that might help anything. I figured I had nothing to lose since the original was already completely lost (my M17x R4 was an Ebay deal, so it's to be expected). It did nothing, and having an admin password did not enable anything new either.
  • Researching the problem generically, the best match I can find is this unsolved support thread from Dell:
    https://www.dell.com/community/Lapt.../Keyboard-is-not-working-in-BIOS/td-p/5095341
    There are other M17x owners with keyboard issues, but not this one. Likewise, there are other articles addressing keyboards not working in the BIOS, but they assume that readers are using a USB keyboard and that PS/2 keyboards will always work. According to Device Manager, my built-in keyboard is a PS/2 keyboard, so that shouldn't be an issue.
The only lead I have left is using an unlocked BIOS. A thread that has been going for almost 10 years now has some screenshots of BIOS options available in the unlocked BIOS that don't exist in the stock BIOS. One of the screenshots shows that there is a submenu entirely for peripherals. There are no screenshots of the menu itself, as everyone was focused just on performance. Below is the link to the thread; the first post has the screenshots:
https://www.techinferno.com/index.php?/topic/1516-m17x-r4-unlocked-bios-versions/

Can anyone confirm if this lead is a viable option? Also, if there's something I might have missed in troubleshooting, please let me know. Like I said at the start, I'm at my wit's end with this one—hence why I've stopped lurking, made an account, and posted this wall of text.
 

MattyB

Resource Administrator / Forum Moderator
Mar 19, 2012
3,209
138
Adelaide, Australia
Hey, did you end up finding a fix for this one?

I've never come across this issue with the M17x keyboard sorry. Does yours have a green or blue tab on the ribbon cable? Technically the R4 needs to have the green tab version. I've heard that the blue version will work for a short time before developing issues.

If you need the unlocked BIOS then I have one here but I don't think it will help

https://www.dropbox.com/s/4qmzb12hcdcnnnf/[FPT]-M17x_R4_BIOS_A11_-_[unlocked]V2.zip?dl=0

I think you'll need these other files to run the flash

https://www.dropbox.com/s/wn9do4bmqgvbb35/fpt.exe?dl=0
https://www.dropbox.com/s/ctyq4gdym6f34kg/prr2.exe?dl=0

Flash at your own risk.
 
Sadly, no. I'm still using a USB keyboard to navigate my BIOS as the need arises.

Both the old and new keyboards have green tabs on their respective ribbon cables. The new one is still working fine.

Thanks for the unlocked BIOS. I will have to try that. As I mentioned at the end of my post, there appears to be a menu for peripherals in the unlocked BIOS. I wonder if my problem might be caused by one of those settings getting flipped by cosmic rays or something. Sometimes stupid problems require stupid theories.
 

MattyB

Resource Administrator / Forum Moderator
Mar 19, 2012
3,209
138
Adelaide, Australia
Possibly. You could try resetting the BIOS back to default and see what happens. Be careful changing settings though as you never know what can happen. If you need help with the unlocked BIOS then there should be a guide on the TechInferno site.
If it's the same as the M18x R2 then you just need to grab a spare USB drive, format it to be Bootable using RUFUS, put all the unzipped files into the USB root menu, restart the laptop and press F12 to get into the Boot Menu, Boot from the USB and run flash.bat to start the flash.
I can't remember if I've ever done it on the M17x though.