test

M17X Windows 7 clean install issues

svendawgg

New Member
Joined
Jan 29, 2014
Messages
4
Hello, this is my first posting on this sight, even though ive used it as a resource in the past a few times. Ill give you a run down as to what I have done so far, and hopefully someone can get this computer working as it should once again.

I made the mistake of installing windows 8 on the laptop. I then found that the switchable graphics didnt work correctly and the laptop would not come back from standby mode.

I then put the windows 7 disk in again and booted from the disk. I erased both partitions that were on the hard disk and started from scratch (i think i did anyhow).

I then used the driver for the "intel rapid storage technology" because the m17x r3 has two 500gb hard drives.

The next step was to allow windows to install. I shut off any updating that windows was going to do automatically.

Then I waited for windows to boot up, I installed the internet driver.

Then I installed the Intel graphics driver (which i keep reading you need to do before I install any amd video drivers)

In the device manager, I only see one video card now, it is the "hd intel graphics family" there is no mention of any vga device, or the Amd Radeon HD 6990M that is in the laptop.

I did attempt to install Catalyst Control center anyhow (from the dell website) and it says that there is an error when I attempt to install it.

I then updated my bios firmware. Still nothing.

I have done this before and everything worked correctly. Whats the deal this time, am i doing something wrong?

This has been almost 3 days of constant work on this laptop attempting to troubleshoot it. I am wondering if I missed a step, maybe Catalyst needs the windows service pack 1 to work... i dunno, please help.

- - - - - Updated; Consecutive Post Auto Merged - - - - -

I got it to show up finally and installed the first driver on the dell website for the 6990m. But when I do the windows update and restart the computer afterwards I have to go back to the device manager and right click on "find new hardware" for it to show up. When I restart after an update the video card seems to disappear.
 

svendawgg

New Member
Joined
Jan 29, 2014
Messages
4
No, when the computer restarts there doesn't appear to be any video card in the bios.

- - - - - Updated; Consecutive Post Auto Merged - - - - -

Just an update, I went through the windows update. The bios does not show any descrete video card now. It boots up with only the Intel 3000 graphics. I cant get anything to show up in the device manager either. How do you get it to show up in the bios?
 

svendawgg

New Member
Joined
Jan 29, 2014
Messages
4
Try to reset or reseat? Has anyone ever seen this before. I completely updated everything else and now have no video card whatsoever. The computer will not detect it, and no drivers will install. Please help.
 

MattyB

Moderator
Joined
Mar 19, 2012
Messages
2,964
You could try clearing the CMOS. Not sure how to do it on the M17x but doing it helped me big time on my M18x after swapping GPUs. You may also still be having Optimus issues. Have you tried switching the graphics on the keyboard? Think it's Function F5. Can't remember right now
 

AeonSoul

Member
Joined
Feb 21, 2012
Messages
1,367
It's an AMD card, not an NVIDIA, so he has no optimus :)

and yeah, RE-SEAT it, as in you open your laptop, unplug the card and plug it back in.
 

svendawgg

New Member
Joined
Jan 29, 2014
Messages
4
Thanks everybody. I physically ininstalled the video card and started up windows. Then I shut down the laptop and put it back in. Works as it should now, except the latest updates wont configure correctly. 13.x ccc drivers. Works as it did before however. Thank you very much.
 

AeonSoul

Member
Joined
Feb 21, 2012
Messages
1,367
Yeah, sometimes if you can't see it in the bios just a simple reseat will fix it.
 
Top