MW3 Choppy

Chrome

Member
Joined
Mar 5, 2012
Messages
30
Hey there all..., i love my m14x, i7-2760, gt555m 3gb, 8gb 1600mhz memory...

but lately..., on a few occasions, either i installed a anti-virus (avg or mcafee), or i downloaded a newer/latest driver for the nvidia and bios,MW3 gameplay's ( sp or mp ) performance dramatically changes..., it becomes unbearably choppy..., and mouse responsiveness' lag the hell out...
and it even comes to a point when even just changing the video settings will cause the game to crash...

ive no problems with the gameplay even after alienrespawn( default driver 269.** )

anyone have any thoughts or advice on this...?
 

MattyB

Moderator
Staff member
Joined
Mar 19, 2012
Messages
2,649
Have you tried turning off your anti-virus before starting up the game. When I had my old Toshiba, I couldn't play MW1 without turning off my anti-virus.
 

AeonSoul

Member
Joined
Feb 21, 2012
Messages
1,380
Just wondering, did you setted for MW3 to use the nvida VGA from the nVidia control panel?
 

Chrome

Member
Joined
Mar 5, 2012
Messages
30
@MattyB
Ive tried turning it off and even uninstalling it and to no avail... and on other Respawns(yes, ive been through a few) i didnt install any anti-virus software... but downloading/updating the driver will cause the choppiness....
it seems that one of the following
-installing an anti-virus
-updating the driver
-updating the BIOS
will cause the game to be choppy, mouse lagginess, and even changing the video settings would result in the game crashing..
or im missing something crucial with what im doing...

@AeonSoul
ive tried to add in in the programs but MW3 doesnt show up..,
when i trace the path to the MW icon on the desktop, all it shows is just a Steam URL, so instead ive set my video options, both on AlienCommandCenter and MediaControl Panel to Maximum Performance. I could tell its using the Nvidia when i start MW coz the fans kick in....
 
Top