New Member
Dec 13, 2018
sydney, ns
2015 was the last time my son tried downloading windows 10 but at that time there were no drivers for support for alienware Dell said they couldn't fix it bought another board still no luck got another cpu a step down from the first one had it to a few places no luck one fellow told me it started to re boot them quit ???? keeps getting the 7 beeps continues and no screen any ideas or know where i can send it too thank you Blair


Resource Administrator / Forum Moderator
Mar 19, 2012
Adelaide, Australia
Have you tried to see if it will load the pre boot assessment? I think you hold the Fn key while starting the machine until it pops up but I can't remember for sure.
If you haven't already, you can try some simple things like unplugging the power adapter and the battery and holding down the power button for 30 secs to drain all power. Then just plug in the adapter and see if it boots. 7 beeps usually means the CPU but if you've replaced the board and CPU then something strange is going on.
If you can get hold of MrFox on here or anywhere (maybe try his MrFoxRox youtube channel), he is the M18x king of the world and if he doesn't know then you're in trouble.