Need help!

blessthenoob

Member
Joined
Jul 7, 2016
Messages
6
Hello all!

I have a problem with my alienware M17x R2, the screen is black. Nothing is showing on it. I can connect it to my tv with ahdmi cable and still the black screen. So im thinking is a video card problem. Searching about the problem online i have found that alienware has some led error codes. Can someone help me with that? The keyboard is getting lighted but num lock,scroll lock and caps lock are off. Anyone has some idea its not the video card or maybe it is....
 

Alienwulf

Member
Joined
Jan 20, 2014
Messages
238
Sounds like a video card to me, first place I would go is get one on Ebay and swap it out. Not hard to do should be some you tube videos on it.
 

blessthenoob

Member
Joined
Jul 7, 2016
Messages
6
Forgot to add, have a dual HD 5870 gpu. I have attached a picture that i have found online. Can i let only 1 gpu inside connected or it wont run like that? I have to buy another gpu like that or i have to buy 2 gpu's if they are both dead?
 

Attachments

  • image.jpeg
    image.jpeg
    111.6 KB · Views: 3

Alienwulf

Member
Joined
Jan 20, 2014
Messages
238
I do believe one is a master card and the other is a slave. System would work off master only but not just a slave. If you hold f8 when powering up will it go into Bios? First thing I would try and don't laugh is unplug system..pull battery..hold power button down for 20 or so seconds then wait 5 or so minutes and re-power system. That would clear any driver issues. It works often on strange problems. If you still have the problem I will give you some links to check out.
 

blessthenoob

Member
Joined
Jul 7, 2016
Messages
6
Didnt try the F8 to see if its going in bios. But i have removed the battery and the bios battery and then hold the power button for 30 seconds and still nothing. I will try the bios when im home. So about the gpu, if i will have to buy it, i will need only one? Thinking of buying the gpu.... Dont know what else i can do, maybe its a faulty motherboard or who knows what else. Your help is much appreciated.
 

Alienwulf

Member
Joined
Jan 20, 2014
Messages
238
Last thing to try would be pull the slave gpu and see it the master is ok. If you still get nothing most likely master or mother board. Either way at that point Ebay is your friend.
 

blessthenoob

Member
Joined
Jul 7, 2016
Messages
6
Yeah. Im thinking to buy a gpu card. Just a silly question. Which one is the master gpu and the slave one? I just started the laptop and tryed to enter bios by pressing F8. No chance to revive it. Gpu ftw! Thanks m8.
 

blessthenoob

Member
Joined
Jul 7, 2016
Messages
6
I have tested the GPU (HD 5870). In the left slot one at a time.(thats the master slot) The laptop starts, nothing on the screen of course. On the keyboard i have a blinking caps lock and num lock. Maybe both of the gpu are dead. How can i test the motherboard? So i can buy a gpu and make it work.
 
Top