X51 Poll - Who is getting one?

Will you be ordering the Alienware X51 Desktop?

  • Yes - It fits my needs

    Votes: 26 54.2%
  • No - I can't find a use for it.

    Votes: 13 27.1%
  • Undecided at the moment.

    Votes: 9 18.8%

  • Total voters
    48
  • Poll closed .

JennyM

Member
Jul 13, 2012
200
0
Ireland
M15x playing up again, last in a looooong list of issues this last year or so.

..... so giving up on it and ordered myself an x51 -

210-AANM Alienware X51 R2 : Standard Base 1 SR
203-40868 D00AR218 1 SR
338-BCBX Intel Core i7-4770 -- [7RPX5N] 1 SR
370-AAMQ 16GB Dual Channel DDR3 at 1600Mhz 1 SR
400-AALK 2TB (64MB Cache) 7200 RPM SATA 6Gb/s 1 SR
403-BBBT Matte Stealth Black with Dark Chrome Accents 1 SR
429-AACU Slot-Loading Dual Layer Blu-ray Reader (BR-ROM, DVD RW, CD-RW) 1 SR
430-XYGB Cyberlink Power DVD BD 1 SR
450-AARL 330W AC Adaptor 1 SR
490-BBFD 2GB GDDR5 NVIDIA GeForce GTX 670 1 SR
555-BBEJ DW 1506 802.11 b/g/n Wi-Fi Wireless LAN 1 SR
555-BBHD WLAN Card DW1506 Driver 1 SR
570-AACL Alienware Standard Optical Mouse 1 SR
580-AAZV UK/Irish (QWERTY) Alienware Multimedia Keyboard 1 SR
619-AAKB Operating System : Windows 8 64bit, English 1 SR
754-81719 3 Years NBD with Premium Phone Support

Hopefully a few trouble-free years of computing ahead... pleeeeeze! lol :)
 

JennyM

Member
Jul 13, 2012
200
0
Ireland
Hi Matty,
Took a break from pc stuff for a while, it was taking over, u know? lol!

Anyhoo, i'm back online, learning how to do the whole torrent thing, its quite fun. Started back on wow again too, but only played a few times in the last fortnight... I kinda prefer the people on the game that I know rather than the game, end up spending more time chatting than actually playing.....

My M15x was getting really sluggish, taking 5 to 6 mins to startup, black screens sometimes on startup, so I just got fed up fixing problems and decided to order an x51 in a fit of pique, lol

Anyway, I think I've made a big mistake, I'm close to sending my x51 back... it arrived yesterday and I keep getting 'Computer not responding' messages when I try to read my external hard drive to transfer files. My lappy is reading the drive with no issues, so its not the drive. Also, my main worry, is that the wireless signal is fluctuating between 1 bar and 3 bars on my x51, but on my M15x which is sitting beside it, I have a full 5 bars. I read up on the dell site last night and there's hundreds of others with the same issue, for over a year now. So I'm having a bit of a panic about it, wondering what have I done.... :(

I'm gonna scour the site here and see if any other alienowners have anything to say about it...
 

JennyM

Member
Jul 13, 2012
200
0
Ireland
Ah, I know a lot of people ended up sorting the problem themselves, but it is over a year since they knew the problem existed and I paid £1425 for it plus 3 yr warranty, so not considering paying for a new wireless adapter...

Finally got the x51 to read my external hard drive though, by plugging it into the ports on the back, instead of the front ... I guess I'm gonna have teething problems, but after spending my savings, I do feel a little bit anxious, lol!!!

- - - - - Updated; Double Post Auto Merged - - - - -

The wireless signal seems to be settling now, I've been downloading wow files for about 9 hours now, and getting a steadyish 3 to 4 bars, so I'm happy enough with that... download rate is around 750 to 850 KB/s which is what my lappy gives me too with its 5 bars or signal. Somewhat relieved and coming to terms with my big spend... xD
 

JennyM

Member
Jul 13, 2012
200
0
Ireland
Hi All,

New to the forum...ordered my X51 R2 last Tuesday (18 June 2013), but very disappointed at long leadtime for delivery, currently sitting at 8 July 2013 (3 weeks)!

That said, I cannot wait for it to arrive.

Thats strange, i ordered mine from UK site 4 days before you... and was shipped the following day, though took I think another 4 days to get here. Keep checking your tracking, it might shorten... welcome to the site nonetheless and gratz on your new AW. :)
 
X51 R2
i7-4770
1tb HD(later SAMSUNG 840 Pro Series 512gb SSD)
8gb RAM
Nvidia GTX 670 2gb

Got mine two weeks ago. Three days later I swapped the HD to an SSD. Thought booting was the only thing I will notice, nope, everything boots up in an instant! Web, games, wow. Best upgrade so far!!! GPU soon, still researching. Drilled some holes in the most hot areas and removed the DVD drive so more air can dissipate the heat.
 

Attachments

  • x51.jpg
    x51.jpg
    88.8 KB · Views: 12
  • x51 2.jpg
    x51 2.jpg
    79.9 KB · Views: 10
Ordered my X51 R2 and looking forward to my first dedicated gaming PC.

4th Generation Intel® Core™ i7-4770 processor
Windows 7 Home Premium, 64Bit
1 Year Alienware Basic Support
AMD Radeon™ R9 270X with 2GB GDDR5
8GB Dual Channel DDR3 at 1600Mhz
1TB SATA 6Gb/s (7,200RPM) 64MB Cache
DW 1550 802.11 b/g/n/ac Wi-Fi + Bluetooth Wireless Combo
Slot-Loading Dual Layer DVD Burner (DVD±RW, CD-RW)
DW 1550 802.11 b/g/n/ac Wi-Fi + Bluetooth Wireless Combo

I had to work within a budget. Im sure i will be happy with this set up. Say's delivery date 17th Nov.

Eddy
 
Hi, just picked up a slightly used x51 r1? i7 2600 3.4ghz 8gb gtx555 1tb bd/dvd, got it on ebay for $500 previous owner didn't use it much got it in the original alienware shipping carton all documentation AW win7 disc & resource disc, I don't think the mouse and keyboard were ever used. I opened it up no dust looked like new...l was getting random bsod win7 with latest nvidia drivers when doing anything video related not necessarily gaming or heavy gpu use. After some trial and error updating all drivers/bios (a14) etc...ended up installing an older nvidia beta driver 301.24 I found by suggestion in a dell forum post and it has been working fine for a few days now...Have loaded up steam and gone through some of my games has been very respectable in performance compared to my other rig. Got this unit for my TV room because of its size and specs. The new r2 units with updated cpu and gpu must really kick some butt!! Will setup speedfan and monitor temps. At some point I will attempt upgrading nvidia drivers again but after a few days of teching and tweaking not in a hurry and no more bsod's not even a single crash or system lock up. Maybe just upgrade to an evga 670/680 or a 760 if it will fit down the road.
 

STDVirus

Member
Nov 30, 2013
101
0
Olympia,wa
congrats they are great machines for the size not much out that can beat them honestly for the size and looks. If you are looking to upgrade the gpu i'd prob go with the 670 FTW edition i think it offer's one of the biggest bang for the bucks with the least amount of trouble. When i got mine it had the GTX 645 and to be honest if i wasn't such a graphics snob that prob would of done me just fine for a while and the GTX 555 is actually faster then the 645. But the 670 would be a huge leap in performance. Looks like you got a good deal as well.