X51 R1: My USB ports are starting to die on me 1 by 1. Any suggestions? R2 power board?

Ghost101

New Member
Jul 8, 2016
2
0
Hi, my first post here :)

I’ve got a problem with 2 of my USB ports that stopped working. One about a year ago, the other about a month ago. Both are USB 2.0 ports on the back of my X51 R1. Weird thing is if I plug my phone or iPod into these 2 ports, my pc detects them and can even charge them, but nothing else (keyboard, mouse, USB stick, nothing).

Solutions on google are mostly driver related when all of the USB ports suddenly stop functioning, which certainly isn’t the case here. What’s more weird is that at one point, the 2nd USB port only worked when I turned off all the lights in my room, which sounds like a power related issue. I disabled USB auto suspend feature, but still no go. They don’t work on Win 10 fresh install either. I ran Dell’s ePSA hardware test at boot but it didn’t detect any problems. Btw, my 1st USB port died about a week after I put Intel 7260ac internal card. Any ideas?

Would ordering R2 power board fix this issue, since I hear it can handle an extra 20W?

I don’t want the 3rd USB port to die on me as I have a lot of things plugged in :(
 

TiredKorok

Member
Jul 14, 2016
8
2
I'm not very experienced but they might be dying because you had too much stuff plugged in to one with a usb bus or something.
I'm also not too sure that ordering a new power board would help, i especially think it wouldnt help the already dying ones :p and if the power part is working but not the logical i cant see why adding more power would help.

That being said my personal action would be to solder in some new usb ports, they might have just simply died. Then i'd go ahead and get the r2 power board because i think your pc will like the extra wiggle room in watts.

Besides that, maybe spread out your devices more across thhe 8 usb ports? Anyways hope that's of some help, though i'd rather someone with more experience reply. Take my advice with a pinch of salt!