x51 R1 Power Board Upgrade Gone Wrong


New Member
Jan 10, 2017
My R1 is an old desktop, probably 5 years old already.

Recently its (second) GPU, GTX 660 died. I would like to take this chance to upgrade it, so I did some extensive research through the forums. I found out that the R1 power board is a bottleneck to better GPUs.

So end up getting a R2 power board (D85RT) from Dell. Managed to replace it in with all the cables attached. But when I tried to on, no power seems to be flowing in the system. Checked the cables, everything is attached, but still no power. But when I fixed back my original R1 power board, everything seems normal.

Before concluding that the R2 power board is faulty, what could be the possible causes preventing it from turning on?

(2x4) 8 GB RAM DDR5
No GPU currently, GTX 1060 otw.
330W PSU
BIOS Ver. A14


New Member
Jan 29, 2017
Have you change power board to the new one?

My R1 almost the same spec and today I replaced powerboard to D85RT. It started to work on the first try. But my system can not detect new gtx 1060. Can't figure out why, gonna try this gpu in a different PC.