X51 R2 with 670 GTX, only runs stable with stock Dell Drivers? Crashes using NVIDIA

johnnobts

New Member
Joined
Nov 20, 2013
Messages
1
I did some searching but haven't found anything posted on this. Have an X51 R2 with the original 670 graphics card. I also have an Nvidia Shield device and wanted to stream my games. In order to do this, needed a newer Nvidia driver. Using any of the new NVIDIA drivers seems to cause instability and random reboots. minidump says its a driver issue. So far have not had this problem running the ones provided on the Dell website, only problem being they are ancient and don't support the Shield. Anyone come up with a fix?

Thus far the only thing that seems to have worked for me is to install the Dell stock driver, then the Nvidia newer drivers over them. If I don't reboot the PC the crashes don't seem to happen. Still, don't like leaving my X51 on all the time. Sorry if this question has been asked and answered. Wondering in the back of my mind if I have a bad 670 or mobo... Anyone else have trouble running the 670 with updated Nvidia drivers?
 

simp0man

Member
Joined
Nov 21, 2013
Messages
5
I have the same GPU but I had Nvidia do the updating not windows(device manager). Use the Geforce Experience program to maintain your GPU. It was today, I tried the device manager to find a new driver for the GPU and it did find something but next thing my Geforce experience program re-updated what i originally had in the first before windows "updated" the driver. I'd stick with the Geforce to handle your GPU needs. Shoot after I first time played BO2 on my x51 this Geforce experience automatically popped up and told me it can optimize my game play. I let it do its job and next time I played BO2 it was much smoother and wow what a difference. One thing I learned, use the HDMI from the GPU, not the default. It runs much better! Hope this helps.
 

bbond007

Member
Joined
Jul 19, 2013
Messages
38
Anyone come up with a fix?

I don't know if I have a fix, but maybe the stock nvidia graphics run the clock faster thus using more power.

I would try and load MSI Afterburner or EVGA Precision and put the power limit to like 75% and see if the problem persists.

Hope that helps!
 
Top